EmailDiscussions.com  

Go Back   EmailDiscussions.com > Email Service Provider-specific Forums > FastMail Forum
Register FAQ Members List Calendar Search Today's Posts Mark Forums Read
Stay in touch wirelessly

FastMail Forum All posts relating to FastMail.FM should go here: suggestions, comments, requests for help, complaints, technical issues etc.

Reply
 
Thread Tools
Old 24 Sep 2015, 07:36 PM   #1
JamieKitson
Member
 
Join Date: Aug 2013
Posts: 54
CardDAV Contact Syncing Working on Windows Phone 8.1 (!!!)

I don't know if anyone else has achieved this yet, but I have been trying for months and months and have finally got CardDAV working on Windows Phone 8.1.
  1. Add an iCloud account.
  2. Set the email address to your fastmail email address, but add "+Default" after the name part so you have, for example "name+Default@fastmail.com".
  3. Put in your password (if you're not aware you can create an alternate login for this so you don't have to use your master password).
  4. Tap "sign in".
  5. Tap the newly created iCloud account.
  6. Change the account name to something meaningful.
  7. Make sure Contacts is ticked to sync.
  8. Untick sync Calendar.
  9. Tap "advanced settings" at the bottom of the page.
  10. Edit the "Contacts server (CardDAV)" to:
    "carddav.messagingengine.com:443/dav/addressbooks/user/username@fastmail.com/Default"
    Obviously changing "username@fastmail.com" as appropriate. Note the missing "https://" and the added port number.
  11. Tap the tick to save your changes.
  12. Your Fastmail contacts should now sync.
Note that you can't use the same account instance on your phone for both Calendar and Contacts because the usernames are different.

https://beta.fastmail.com/help/techn...44101#contacts
JamieKitson is offline   Reply With Quote

Old 14 Oct 2015, 05:57 PM   #2
JamieKitson
Member
 
Join Date: Aug 2013
Posts: 54
I have seen a slight oddity with this. I started by deleting all my Fastmail contacts and importing a file exported from Gmail. At this point my contacts were all syncing properly except for their phone numbers(!) I found that if I did an edit -> save in the Fastmail web UI then a contact would fully sync. I managed to get all of my contacts syncing properly by doing an export in Fastmail and then Importing that file over the existing contacts. I don't seem to have ended up with any duplicates, and my contacts now seem to be syncing with my Windows Phone properly.
JamieKitson is offline   Reply With Quote
Old 15 Oct 2015, 05:10 AM   #3
Berenburger
The "e" in e-mail
 
Join Date: Sep 2004
Location: The Netherlands
Posts: 2,252
Thanks! I will try it on my Lumia. No trick yet to get CalDAV working?
Berenburger is offline   Reply With Quote
Old 8 Nov 2016, 07:33 AM   #4
Berenburger
The "e" in e-mail
 
Join Date: Sep 2004
Location: The Netherlands
Posts: 2,252
Updated!

Quote:
Originally Posted by JamieKitson View Post
I don't know if anyone else has achieved this yet, but I have been trying for months and months and have finally got CardDAV working on Windows Phone 8.1.
  1. Add an iCloud account.
  2. Set the email address to your fastmail email address, but add "+Default" after the name part so you have, for example "name+Default@fastmail.com".
  3. Put in your password (if you're not aware you can create an alternate login for this so you don't have to use your master password).
Replace line 3 with a New App Password in the App Passwords section. Choose CardDAV as the type of data this app needs access to.
Quote:
  1. Tap "sign in".
  2. Tap the newly created iCloud account.
  3. Change the account name to something meaningful.
  4. Make sure Contacts is ticked to sync.
  5. Untick sync Calendar.
  6. Tap "advanced settings" at the bottom of the page.
  7. Edit the "Contacts server (CardDAV)" to:
    "carddav.messagingengine.com:443/dav/addressbooks/user/username@fastmail.com/Default"
    Obviously changing "username@fastmail.com" as appropriate. Note the missing "https://" and the added port number.
7. You can also use the new fastmail.com domain here: carddav.fastmail.com instead of carddav.messagingengine.com.

Quote:
  1. Tap the tick to save your changes.
  2. Your Fastmail contacts should now sync.
Note that you can't use the same account instance on your phone for both Calendar and Contacts because the usernames are different.

https://beta.fastmail.com/help/techn...44101#contacts
Works also on Windows Mobile 10.

Last edited by Berenburger : 8 Nov 2016 at 08:00 AM.
Berenburger is offline   Reply With Quote
Old 8 Nov 2016, 07:58 AM   #5
Berenburger
The "e" in e-mail
 
Join Date: Sep 2004
Location: The Netherlands
Posts: 2,252
Quote:
Originally Posted by Berenburger View Post
Thanks! I will try it on my Lumia. No trick yet to get CalDAV working?
See this thread.
Berenburger is offline   Reply With Quote
Old 15 Dec 2016, 02:45 PM   #6
Derok
Junior Member
 
Join Date: Dec 2016
Posts: 1
Quote:
Originally Posted by Berenburger View Post
7. You can also use the new bathmate x20 reviews fastmail.com domain here: carddav.fastmail.com instead of carddav.messagingengine.com.


Works also on Windows Mobile 10.
Excellent, you guys are so helpful. It took a while but I've got CardDAV working on my new W10 phone. Thanks peeps.

Last edited by Derok : 22 Aug 2017 at 08:45 PM.
Derok is offline   Reply With Quote
Old 29 Dec 2016, 10:33 AM   #7
rockman
Senior Member
 
Join Date: Aug 2013
Location: Seattle
Posts: 115
Thumbs up

Similar steps work on Windows 10 desktop for both CardDAV and CalDAV!
rockman is offline   Reply With Quote
Old 15 Feb 2017, 04:16 AM   #8
pjroutledge
Member
 
Join Date: Jan 2010
Location: Melbourne, Oz
Posts: 35
Quote:
Originally Posted by JamieKitson View Post
...

7. Edit the "Contacts server (CardDAV)" to:
"carddav.messagingengine.com:443/dav/addressbooks/user/username@fastmail.com/Default"
Obviously changing "username@fastmail.com" as appropriate. Note the missing "https://" and the added port number.

...
I could only get this to work on my Lumia 950 Windows 10 phone when I inserted the "https://" prefix.

Working now though. I'm happy.
pjroutledge is offline   Reply With Quote
Old 15 Feb 2017, 07:44 AM   #9
Berenburger
The "e" in e-mail
 
Join Date: Sep 2004
Location: The Netherlands
Posts: 2,252
Quote:
Originally Posted by pjroutledge View Post
Working now though. I'm happy.
Have this several months working. No issues either.
Berenburger is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Forum Jump


All times are GMT +9. The time now is 05:27 PM.

 

Copyright EmailDiscussions.com 1998-2013. All Rights Reserved. Privacy Policy