EmailDiscussions.com  

Go Back   EmailDiscussions.com > Email Service Provider-specific Forums > FastMail Forum
Register FAQ Members List Calendar Search Today's Posts Mark Forums Read
Stay in touch wirelessly

FastMail Forum All posts relating to FastMail.FM should go here: suggestions, comments, requests for help, complaints, technical issues etc.

Reply
 
Thread Tools
Old 24 Mar 2009, 06:51 AM   #1
mcevg
Junior Member
 
Join Date: Mar 2009
Posts: 3
Apple Mail invisible column(s) content

Hi all,

I am using Apple Mail to work with Fastmail IMAP account for a long time.

A couple of days ago all the incoming mail starts to show empty "From" and "Subject" fields in Mail application (upper right part of Mail window). In lower right part (preview) everything was fine. If I opened the message everything works fine.

All the other IMAP accounts (Apple MobileMe and third party one) works fine with Apple Mail so it looks like it is Fastmail problem.

The same time all old correspondence of Fastmail account looks good in Apple Mail.

I am the only one who have this problem?
mcevg is offline   Reply With Quote

Old 24 Mar 2009, 07:32 AM   #2
kt0157
Junior Member
 
Join Date: Jan 2006
Posts: 6
Me too

Yeah, my iPhone mail is (no subject) (no sender). And the Mac's own Mail is just blank.

Very annoying.
kt0157 is offline   Reply With Quote
Old 24 Mar 2009, 08:19 AM   #3
brong
The "e" in e-mail
 
Join Date: Jul 2004
Location: Melbourne, Australia
Posts: 2,693

Representative of:
Fastmail.fm
Are you still having issues?

I managed to roll out a very annoying bug where the cached details for the final message in the folder were being returned as blank, but it's been fixed now. It was only there for about 20 minutes.
brong is offline   Reply With Quote
Old 24 Mar 2009, 09:07 AM   #4
kt0157
Junior Member
 
Join Date: Jan 2006
Posts: 6
Still a problem

Quote:
Originally Posted by brong View Post
Are you still having issues?

I managed to roll out a very annoying bug where the cached details for the final message in the folder were being returned as blank, but it's been fixed now. It was only there for about 20 minutes.
Yep, still a problem. Just tested it again: sent a test email to my Fastmail account and cc'd it to my Gmail account. The Mac Mail doesn't have a problem when it receives the mail on either account. The iPhone has "(no subject)" and "(no sender)" on the Fastmail account, but no problems with the same message on the Gmail account. I think the Mac Mail only gets upset and displays blank columns for messages that the iPhone has already got to

Curiously, a friend with an iPod touch doesn't have this mail problem with their Fastmail account.
kt0157 is offline   Reply With Quote
Old 24 Mar 2009, 01:28 PM   #5
brong
The "e" in e-mail
 
Join Date: Jul 2004
Location: Melbourne, Australia
Posts: 2,693

Representative of:
Fastmail.fm
Yeah, I found the additional - actually two more bugs in the code. I went back and did a line-by-line review of the patch that went in. There were a couple of misleading comments that had caused me to pass the wrong data to the fetch functions when I rewrote the caching interface.

Sorry about that. I've rolled out the fix.

Re: your friend. This change was only done to a single store, so it only affects a little over 1% of our users. You were just (un)lucky I guess! We did it to the store that we are on, so we would see any issues first, hopefully.

Everyone else will get it in a couple of days, assuming nothing else gets found. The caching changes are just incidental, the really interesting bits are in search and characterset handling, which is massively improved. Sieve scripts can now examine decoded data, and searches handle whitespace more sanely.
brong is offline   Reply With Quote
Old 24 Mar 2009, 06:16 PM   #6
mcevg
Junior Member
 
Join Date: Mar 2009
Posts: 3
Smile @brong - Many thanks, it works just fine now.

@brong

Fastmail is awesome service, thank you!
mcevg is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Forum Jump


All times are GMT +9. The time now is 01:23 AM.

 

Copyright EmailDiscussions.com 1998-2013. All Rights Reserved. Privacy Policy