EmailDiscussions.com  

Go Back   EmailDiscussions.com > Email Service Provider-specific Forums > FastMail Forum
Register FAQ Members List Calendar Search Today's Posts Mark Forums Read
Stay in touch wirelessly

FastMail Forum All posts relating to FastMail.FM should go here: suggestions, comments, requests for help, complaints, technical issues etc.

Reply
 
Thread Tools
Old 11 Jul 2009, 02:42 AM   #1
zaaz777
Essential Contributor
 
Join Date: Jul 2001
Posts: 332
Make Fastmail The Default Client

As I am using Fastmail web interface exclusively to download ,read and reply to emails I wish to make Fastmail my default email client so that whenever I click any mailto links the Fastmail compose page should open.Could anyone give me instructions how I could do this.Incidently I have a Fastmail Professional account with my domain hosted with this account.
zaaz777 is offline   Reply With Quote

Old 11 Jul 2009, 03:01 AM   #2
Sherry
 Moderator 
 
Join Date: Dec 2002
Location: USA
Posts: 8,686
Hi zaaz777,

One way to do this is by using FastCheck. It's a little program an FM user wrote that runs in the systray (windows) and instantly notifies you of email coming into your Inbox (and other folders at a pre-set time) then takes you to the web to read them. When your account is setup in it you will see some buttons at the bottom (when looking at the account). Just click on the one that says "Set as default email account". Now the mailto links will go to FM. Once that is done you can continue to be notified of incoming email or just stop using FastCheck. The mailto tag will still work.

If you are using Firefox Rob has instructions for setting it up.
Using Mailto: on FireFox 3

Sherry
Sherry is offline   Reply With Quote
Old 11 Jul 2009, 05:59 AM   #3
SamVilde
Essential Contributor
 
Join Date: Apr 2002
Location: New York City
Posts: 236
& if on a mac

This tiny thing improved my computer-life by ten:

http://belkadan.com/webmailer/

Fastcheck doesn't (didn't?) work on a mac - additionally, it does a ton of things. I just wanted mailto links to open my fastmail page. Which this does.

The only downside is that if I have my mail open in one tab and click a mailto link in a different tab, the program doesn't realize that my mail page is open ... and opens a third. But this is a minor hassle, all things considered.
SamVilde is offline   Reply With Quote
Old 11 Jul 2009, 11:08 PM   #4
akorvemaker
Master of the @
 
Join Date: Nov 2002
Location: Canada
Posts: 1,001
If you happen to use the Opera web browser, it's as simple as picking from a drop-down menu in the upcoming version 10.

If the tips so far don't help, let us know which operating system (Windows XP, Mac OS X, etc) and web browser (Internet Explorer, Firefox, etc.) you use and we can give clearer suggestions.

Andy
akorvemaker is offline   Reply With Quote
Old 12 Jul 2009, 01:58 AM   #5
zaaz777
Essential Contributor
 
Join Date: Jul 2001
Posts: 332
I am usinf Firefox 3.5 I tried out Rob's instructions but after pasting the javascript in a blank address bar in a new tab the page is not opening at all I have java script enebled in options.Maybe I should go with Fastcheck can anybody help me out with Rob's intructions?
zaaz777 is offline   Reply With Quote
Old 13 Jul 2009, 01:52 AM   #6
zaaz777
Essential Contributor
 
Join Date: Jul 2001
Posts: 332
I am awaiting for anymore help and instructions on how to set up Fastmail as the default email client
zaaz777 is offline   Reply With Quote
Old 13 Jul 2009, 02:04 AM   #7
akorvemaker
Master of the @
 
Join Date: Nov 2002
Location: Canada
Posts: 1,001
I haven't forgotten about you. Honest!

I'm away from my pc right now, but I should be able to look at it in about 6 hours if no one else does before then.

Andy
akorvemaker is offline   Reply With Quote
Old 13 Jul 2009, 02:45 AM   #8
zaaz777
Essential Contributor
 
Join Date: Jul 2001
Posts: 332
Sure Andy take your time I will wait for your instructions
zaaz777 is offline   Reply With Quote
Old 13 Jul 2009, 08:44 AM   #9
akorvemaker
Master of the @
 
Join Date: Nov 2002
Location: Canada
Posts: 1,001
Ok. I just tried Rob's instructions, and I think it worked mostly as he said.

Steps 1-5 were the same.
Step 6: The same as well, I think. No particular page loaded, but it dropped down a bar at the top of the window (like when it's asking to remember passwords) asking permission to add the mailto handler.
Step 7: the same.
Step 8: Not sure if this is necessary, but I went to Tools... Options. In the Applications section I searched for "mail". The "mailto" content type came up, and from the drop-down list for Actions I selected FastMail. "Always ask" had been selected before.

I'm also using Firefox 3.5. It looks like it worked for me. Clicking a mailto link in Firefox brought me to the FM login page. I logged in, and it took me to the compose screen with the To address filled out.

If you try it again and it doesn't work, possibly an extension/add-on is causing a conflict? (That's my first guess)

Andy
akorvemaker is offline   Reply With Quote
Old 13 Jul 2009, 06:23 PM   #10
zaaz777
Essential Contributor
 
Join Date: Jul 2001
Posts: 332
Still does not work for me.I have disabled all addons in FF3.5
I followed the following instructions:-
1. Type "about:config" in the address bar
2. Search for allowRegisterFromDifferentHost, and it should find an entry called gecko.handlerService.allowRegisterFromDifferentHost
3. Right-click the entry and select Toggle to make it true (this opens a temporary security hole we close in step 7 below)
Steps 1 and 2 went off Ok
Step 3 when I right click on gecko.handlerService.allowRegisterFromDifferentHost
There is no option called Toggle
These are the following entries:-
Open link in new window
Open link in a new tab
Bookmark this link
Save link as
Save link
Copy link Location
Properties
Auto pager
I do not see anything as Toggle

Only if I can solve no 3 then I can proceed next
Can you help?
zaaz777 is offline   Reply With Quote
Old 13 Jul 2009, 11:01 PM   #11
akorvemaker
Master of the @
 
Join Date: Nov 2002
Location: Canada
Posts: 1,001
That sounds weird. It's treating the preferences like normal links.

For me, double-clicking anywhere on that line (either on "gecko.handlerService...." or where it says "false", for example) causes it to switch to True. Does that work for you?

Andy
akorvemaker is offline   Reply With Quote
Old 14 Jul 2009, 02:20 AM   #12
zaaz777
Essential Contributor
 
Join Date: Jul 2001
Posts: 332
Quote:
Originally Posted by akorvemaker View Post
That sounds weird. It's treating the preferences like normal links.

For me, double-clicking anywhere on that line (either on "gecko.handlerService...." or where it says "false", for example) causes it to switch to True. Does that work for you?

Andy
No it is still not working I mhave spent almost 2 hours trying to sort out things but to no avail .Can anybody help or else I just have to give up and think of Fastcheck how good is that?
zaaz777 is offline   Reply With Quote
Old 14 Jul 2009, 02:55 AM   #13
akorvemaker
Master of the @
 
Join Date: Nov 2002
Location: Canada
Posts: 1,001
To me, it sounds like the about:config section of Firefox isn't working properly. I did a quick search and didn't find any obvious fixes for it. (I could be wrong too...)

I don't have any ideas offhand. FastCheck might be the simpler option.

Andy
akorvemaker is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Forum Jump


All times are GMT +9. The time now is 11:20 PM.

 

Copyright EmailDiscussions.com 1998-2013. All Rights Reserved. Privacy Policy