EmailDiscussions.com  

Go Back   EmailDiscussions.com > Email Service Provider-specific Forums > FastMail Forum
Register FAQ Members List Calendar Search Today's Posts Mark Forums Read
Stay in touch wirelessly

FastMail Forum All posts relating to FastMail.FM should go here: suggestions, comments, requests for help, complaints, technical issues etc.

Reply
 
Thread Tools
Old 4 Jul 2009, 02:13 AM   #1
zaaz777
Essential Contributor
 
Join Date: Jul 2001
Posts: 332
Problem to Login With Own Domain

I have a Fastmail Professional Account .I am using my domain abc.com I have created a user [email protected] with admin rights.
I can login at www.fastmail.fm with my user name [email protected] along with my password.All functions working fine here
Now the problem I am facing is when I try to open the login page http://mail.abc.com I am directed to a weird webpage which has no relevence.
Incidently I have pointed my DNS entries at my domain registar to
ns1.messagingengine.com
ns2.messagingengine.com
In future I wish to login at http://mail.abc.com
Can any body tell me what I am doing wrong or what is the solution?
Thanks
zaaz777 is offline   Reply With Quote

Old 4 Jul 2009, 02:43 AM   #2
zaaz777
Essential Contributor
 
Join Date: Jul 2001
Posts: 332
Please can anybody help and give me a solution?
zaaz777 is offline   Reply With Quote
Old 4 Jul 2009, 02:45 AM   #3
n5bb
Intergalactic Postmaster
 
Join Date: May 2004
Location: Irving, Texas
Posts: 8,484
Please try the following. I'm assuming that you are using Fastmail to publish your DNS, since you say your NS entries point to Fastmail.
  • Log into your Fastmail account.
  • Look at the Options>Custom DNS screen.
  • In the Domain section, you should see your domain.
  • In the DNS Mode section, do you see Standard DNS? If so, then you will see at the bottom in the Standard DNS section a listing showing how your DNS is set up automatically. You should see webmail login - http://mail.abc.com --- note that there is no "www" in this URL.
  • If you have decided to use Custom DNS mode, you will have to enter these items yourself. Ask if you are confused by this, but you shouldn't be using Custom DNS mode unless you have specific needs which require a nonstandard setup.
  • After making DNS changes, you will need to wait for the time given by the TTL value until the changes propogate through the Internet. So if your TTL is set to 3600 (seconds), it will take at least one hour for the DNS change to work.
  • At http://mail.abc.com, you should see a simple login screen. You will need to use your main Fastmail login email address (not any alias in your domain) as your Username. You can use the Options>Alternative Logins screen to add additional Passwords, but the Username is always your main Fastmail email address.
Bill
n5bb is offline   Reply With Quote
Old 4 Jul 2009, 03:20 AM   #4
zaaz777
Essential Contributor
 
Join Date: Jul 2001
Posts: 332
Quote:
Originally Posted by n5bb View Post
Please try the following. I'm assuming that you are using Fastmail to publish your DNS, since you say your NS entries point to Fastmail.
  • Log into your Fastmail account.
  • Look at the Options>Custom DNS screen.
  • In the Domain section, you should see your domain.
  • In the DNS Mode section, do you see Standard DNS? If so, then you will see at the bottom in the Standard DNS section a listing showing how your DNS is set up automatically. You should see webmail login - http://mail.abc.com --- note that there is no "www" in this URL.
  • If you have decided to use Custom DNS mode, you will have to enter these items yourself. Ask if you are confused by this, but you shouldn't be using Custom DNS mode unless you have specific needs which require a nonstandard setup.
  • After making DNS changes, you will need to wait for the time given by the TTL value until the changes propogate through the Internet. So if your TTL is set to 3600 (seconds), it will take at least one hour for the DNS change to work.
  • At http://mail.abc.com, you should see a simple login screen. You will need to use your main Fastmail login email address (not any alias in your domain) as your Username. You can use the Options>Alternative Logins screen to add additional Passwords, but the Username is always your main Fastmail email address.
Bill

Dear nfbb,
Thanks for your prompt reply
I followed these steps as instructed
a}Log on to Fastmail
b}Options>Custom DNS
I GOT THE FOLLOWING MESSAGE

Every virtual domain automatically has DNS records published by our name servers and this screen lets you control what those DNS records are. Important: To use these records, you must set the name servers for your domain to our two servers below. If you don't do this and use an external name service provider, the settings below will have absolutely no effect on your domain.

ns1.messagingengine.com
ns2.messagingengine.com

Choose the domain you want to control the DNS for
Domain
Domain You haven't configured any virtual domains
zaaz777 is offline   Reply With Quote
Old 4 Jul 2009, 03:21 AM   #5
zaaz777
Essential Contributor
 
Join Date: Jul 2001
Posts: 332
Please help this is frustrating
zaaz777 is offline   Reply With Quote
Old 4 Jul 2009, 03:46 AM   #6
n5bb
Intergalactic Postmaster
 
Join Date: May 2004
Location: Irving, Texas
Posts: 8,484
It sounds to me as if the nameservers (NS) for your domain aren't pointing to Fastmail yet. There can be a delay before this change is active, depending on how your registrar has this set up. You can check this as follows:
  • Go to http://www.zoneedit.com/lookup.html
  • In the DNS Lookup column, enter your domain name in 1.
  • Select Name Server (NS) in 2.
  • Click Look it up in 4.
  • The results should be:
    • (your domain name) NS ns1.messagingengine.com.
    • (your domain name) NS ns2.messagingengine.com.
  • Until this is OK, you can't use the Fastmail Custom DNS screen features.
Then you need to check the Custom DNS screen described below, then the Virtual Aliases screen.

Bill
n5bb is offline   Reply With Quote
Old 4 Jul 2009, 06:17 PM   #7
zaaz777
Essential Contributor
 
Join Date: Jul 2001
Posts: 332
I followed your instructions at zone edit and these are the results:-
DNS Lookup Results
Host Type Value
fazals.in NS ns1.messagingengine.com.
fazals.in NS ns2.messagingengine.com.
I then logged onto www.fastmail.fm with my ID [email protected]
Then Options>Custom DNS and these are the results:-
Custom DNS

Every virtual domain automatically has DNS records published by our name servers and this screen lets you control what those DNS records are. Important: To use these records, you must set the name servers for your domain to our two servers below. If you don't do this and use an external name service provider, the settings below will have absolutely no effect on your domain.

ns1.messagingengine.com
ns2.messagingengine.com

Choose the domain you want to control the DNS for
Domain
Domain You haven't configured any virtual domains
The same problem persists
Do I have enter the MX records also at my domain registar name.com
Can anybody solve my problem please?
zaaz777 is offline   Reply With Quote
Old 4 Jul 2009, 11:25 PM   #8
zaaz777
Essential Contributor
 
Join Date: Jul 2001
Posts: 332
I can login using http://mail.mydomain.tld now that problem is solved but when I go to options >custom DNS I get this same message
Custom DNS

Every virtual domain automatically has DNS records published by our name servers and this screen lets you control what those DNS records are. Important: To use these records, you must set the name servers for your domain to our two servers below. If you don't do this and use an external name service provider, the settings below will have absolutely no effect on your domain.

ns1.messagingengine.com
ns2.messagingengine.com

Choose the domain you want to control the DNS for
Domain
Domain You haven't configured any virtual domains
What could be the problem as I cannot use this custom DNS feature
Could anybody please advise me?
zaaz777 is offline   Reply With Quote
Old 5 Jul 2009, 08:04 AM   #9
n5bb
Intergalactic Postmaster
 
Join Date: May 2004
Location: Irving, Texas
Posts: 8,484
Have you followed the instructions at the bottom of the Options>Virtual Domains screen? Your domain should be shown at the bottom, with the DNS status set to "Us". And you then need at least one entry in the Virtual Aliases table on that screen.

Bill
n5bb is offline   Reply With Quote
Old 5 Jul 2009, 09:55 AM   #10
Terry
The "e" in e-mail
 
Join Date: Jul 2002
Location: VK4
Posts: 2,719
sometimes domains take 24-48 hours to propagate....
Terry is offline   Reply With Quote
Old 5 Jul 2009, 04:05 PM   #11
zaaz777
Essential Contributor
 
Join Date: Jul 2001
Posts: 332
Quote:
Originally Posted by n5bb View Post
Have you followed the instructions at the bottom of the Options>Virtual Domains screen? Your domain should be shown at the bottom, with the DNS status set to "Us". And you then need at least one entry in the Virtual Aliases table on that screen.

Bill
I went to Options>Personal Domains
[In Fastmail Professional in the Options screen it shows as Personal Domains and not Virtual Domains]
My Domain is not shown at the bottom,I see this screen
Virtual Domains
You may add virtual domains using the list below. We DO NOT purchase the domains for you, you must purchase your domain name from a domain name reseller. However, we can host DNS records for you, either NS (name server) or MX (mail exchanger).

Once you have purchased your domain, you can enter it into the table below. You must then add at least one alias to the above table in that domain. To activate the domain, you need to point the DNS to us.

See the Help link for more details.

Save changes No Domains
When I go down and try to add my domain I see this message
The data you entered contains some errors
The virtual domain already exists and is in use

Forum users n5bb or Terry or any other users of this forum can you help me out?
If there are any of the Fastmail staff who see this post can you help?
Incidently this is a Fastmail Pro account for which I pay $59.95 a year
I can receive and send mail but the problem is the Options >Custom DNS and Options>Personal Domains
Awaiting a solution to this problem
zaaz777 is offline   Reply With Quote
Old 5 Jul 2009, 05:20 PM   #12
Terry
The "e" in e-mail
 
Join Date: Jul 2002
Location: VK4
Posts: 2,719
mine is shown but not in the where you put domain its just above it in small print...perhaps yours is the same....perhaps its already in there ?
Terry is offline   Reply With Quote
Old 5 Jul 2009, 07:03 PM   #13
zaaz777
Essential Contributor
 
Join Date: Jul 2001
Posts: 332
No the domain is not there on the right hand side it says No Domains
How do I use the Domain Control panel when there is no domain showing at all
zaaz777 is offline   Reply With Quote
Old 5 Jul 2009, 07:19 PM   #14
Terry
The "e" in e-mail
 
Join Date: Jul 2002
Location: VK4
Posts: 2,719
I don't understand you say there is nothing on the right hand side.....do you click on VIRTUAL DOMAINS
if you mean where you add your own e-mail address that is on the left in the box then click done it will go to the right hand side if that is what you mean.
You should have NAME then DOMAIN then TARGET you put in you name the domain should be there then click changes.

Is your damain in the middle of the domain page ?
Terry is offline   Reply With Quote
Old 5 Jul 2009, 07:57 PM   #15
zaaz777
Essential Contributor
 
Join Date: Jul 2001
Posts: 332
This is a Fastmail Pro account and my domain DNS is pointing to Fastmail services.Receive and send email working fine.
I can open the login page by typing http://mail.mydomain.tld
My email ID created is [email protected]
I can login with just typing abc as the login ID
When I go to Options>Personal Domains
Under Virtual Domains my domain is not seen I only see No Domains
Can you help?
zaaz777 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Forum Jump


All times are GMT +9. The time now is 11:16 PM.

 

Copyright EmailDiscussions.com 1998-2013. All Rights Reserved. Privacy Policy