EmailDiscussions.com  

Go Back   EmailDiscussions.com > Email Service Provider-specific Forums > FastMail Forum
Register FAQ Members List Calendar Search Today's Posts Mark Forums Read
Stay in touch wirelessly

FastMail Forum All posts relating to FastMail.FM should go here: suggestions, comments, requests for help, complaints, technical issues etc.

Reply
 
Thread Tools
Old 12 Jun 2020, 11:57 PM   #16
ewal
Master of the @
 
Join Date: Apr 2002
Location: London, UK
Posts: 1,327
Quote:
Originally Posted by hadaso View Post
This doesn't happen to me. It might be browser dependent, so I guess it should be reported with the details of the browser used.


I also tried it on the phone (Samsung Galaxy) and there the whole address is editable, but if I change the domain I get an error message when I try to send saying that the domain must match the domain in the identity.
Thanks hadaso, let me play around with different browsers/apps and see if things are different. If I still have an issue I will raise a ticket. Meantime hope life is good. Ed
ewal is offline   Reply With Quote
Old 11 Jul 2020, 10:11 AM   #17
Grhm
Essential Contributor
 
Join Date: Mar 2007
Location: UK
Posts: 221
Quote:
Originally Posted by ewal View Post
This is not working for me properly.
I've never experienced that - it works fine for me - but I've noticed a slight change in behaviour recently. I was wondering if Fastmail have changed something to address the problem you describe. Is it still happening?
Grhm is offline   Reply With Quote
Old 11 Jul 2020, 06:05 PM   #18
ewal
Master of the @
 
Join Date: Apr 2002
Location: London, UK
Posts: 1,327
Quote:
Originally Posted by Grhm View Post
I've never experienced that - it works fine for me - but I've noticed a slight change in behaviour recently. I was wondering if Fastmail have changed something to address the problem you describe. Is it still happening?
Hi Grhm (graham?)

Still the same issue. I tried using the web inteface in both Chrome and Edge. The subdomain.domain.tld part is not directly editable - instead if I click on that field it gets pushed to the right and opens up an empty field allowing me to add anything. So effectively I get a nested subdomain in the form of [email protected]

Interestingly when I reply using a dedicated Fastmail app (Android in my case) I can edit the subdomain part but when I 'send' I get a pop up with following:

Quote:
Send Failed!
This email address is invalid (......)
Ed
ewal is offline   Reply With Quote
Old 4 Feb 2021, 05:48 AM   #19
tlvee
Senior Member
 
Join Date: Jan 2002
Location: Seattle, WA
Posts: 172
Smile

Quote:
Originally Posted by hadaso View Post
Relationships have ups and down, but sometimes something happens that reminds you why you fell in love in the first place.

A little more research into it: I click Compose and then select a *@domain identity. The name is an editable box populated with my name (defined in the identity). The localpart is an empty editable box that I have to type something into. The domain is also in a box that looks editable, but is only partially editable: clicking on it moves the domain to the right and creates an editable box where a subdomain can be typed. So it allows using any email address in the domain and all its subdomains, but not an email address from another domain. I think I can live with that (I haven't tried but perhaps it is possible to actually change the domain using the browser's "inspect element" facility. I use it sometime to edit the source of the email text if I need something that's not available in the interface, like sub-subscripts).

So I'm quite happy today: the issue discussed here seems to be resolved. Replying to emails with custom subdomains became much more streamlined: previously I had to remember before hitting reply to copy the email address i want to use for the reply, so I can paste it into the "From" field after choosing an editable identity. Now it just opens the Compose screen with the right address populating the From field. Another little issue was resolved here; Previously when choosing an editable identity the localpart was populated with the localpart from the previous identity used, which is often not the localpart I want. Several times I forgot to edit it before hitting "send". Now it opens with an empty localpart so something must be typed to make it valid. To me it's an improvement.


So right now I'm happy, until the next issue (that's the way marriage works...) Now I would be even happier if a little action is added to the Compose screen to switch from "reply" to "reply all", because ever so often I click "reply" and only then realize I actually wanted to "reply all" (or some). I guess I'm not the only one with this little problem.
I'm a little late to recognizing this new ability and very happy to have it. One question... has anybody been able to make the *@domain.com sending identity the default identity? I ask because I often accidentally use my personal address when sending work emails to my dismay. This would remind me.
tlvee is offline   Reply With Quote
Old 4 Feb 2021, 11:05 AM   #20
xyzzy
Essential Contributor
 
Join Date: May 2018
Posts: 334
Quote:
Originally Posted by tlvee View Post
I'm a little late to recognizing this new ability and very happy to have it. One question... has anybody been able to make the *@domain.com sending identity the default identity? I ask because I often accidentally use my personal address when sending work emails to my dismay. This would remind me.
Why don't you just dedicate an actual alias or one name from that universe of *@domain.com as the default sending address?
xyzzy is offline   Reply With Quote
Old 7 Feb 2021, 11:24 AM   #21
Grhm
Essential Contributor
 
Join Date: Mar 2007
Location: UK
Posts: 221
Quote:
Originally Posted by tlvee View Post
I often accidentally use my personal address when sending work emails to my dismay.
You can guard against inadvertently revealing your main personal FM address by setting the default sending identity to be something you have never used, but which is different from your main FM address: If you inadvertently send from that address it's no big deal, you can just change the default to something else.
Grhm is offline   Reply With Quote
Old 7 Feb 2021, 02:25 PM   #22
tlvee
Senior Member
 
Join Date: Jan 2002
Location: Seattle, WA
Posts: 172
Thanks @xyzzy and @grhm for your replies. Probably I wasn't very clear in my earlier post. My work email is outside of fastmail (a university), so when I accidentally compose a work email with my personal domain as sender, it gets confusing for the recipient who now has two email addresses for me.

What I wish is that I could always be prompted (when composing a new email) for what my sending address should be, i.e. a tech solution for a human problem
tlvee is offline   Reply With Quote
Old 7 Feb 2021, 05:12 PM   #23
Grhm
Essential Contributor
 
Join Date: Mar 2007
Location: UK
Posts: 221
I don't know any way of getting it to force you to select a sending identity, but I suggest you set the 'nickname'* of your default identity to something that will jump out at you, such as "⚠️💥❌❎CHANGE THIS!!❎❌💥⚠️"
(Since I did that, I've not made that mistake...)


* To set the 'nickname' go to
Settings > Customise > Sending identities > [Name of identity] > Show advanced preferences > Nickname

Last edited by Grhm : 7 Feb 2021 at 06:13 PM. Reason: Instructions to set 'nickname'
Grhm is offline   Reply With Quote
Old 9 Feb 2021, 05:13 AM   #24
tlvee
Senior Member
 
Join Date: Jan 2002
Location: Seattle, WA
Posts: 172
Smile

Ha! Good idea...

Quote:
Originally Posted by Grhm View Post
I don't know any way of getting it to force you to select a sending identity, but I suggest you set the 'nickname'* of your default identity to something that will jump out at you, such as "⚠️💥❌❎CHANGE THIS!!❎❌💥⚠️"
(Since I did that, I've not made that mistake...)


* To set the 'nickname' go to
Settings > Customise > Sending identities > [Name of identity] > Show advanced preferences > Nickname
tlvee is offline   Reply With Quote
Old 9 Feb 2021, 11:02 PM   #25
JeremyNicoll
Essential Contributor
 
Join Date: Dec 2017
Location: Scotland
Posts: 241
Quote:
Originally Posted by Grhm View Post
I don't know any way of getting it to force you to select a sending identity, but I suggest you set the 'nickname'* of your default identity to something that will jump out at you, such as "⚠️💥❌❎CHANGE THIS!!❎❌💥⚠️"
(Since I did that, I've not made that mistake...)


* To set the 'nickname' go to
Settings > Customise > Sending identities > [Name of identity] > Show advanced preferences > Nickname

I've got the nickname for my default id set to, simply, "Jeremy Nicoll - SAFE DEFAULT SENDING ID" which is almost enough to catch my eye reliably. But I see no way, in Settings (etc), to introduce colour to that, which would help a lot. Is it possible, or was your use of colour above just for the benefit of this forum?
JeremyNicoll is offline   Reply With Quote
Old 9 Feb 2021, 11:12 PM   #26
Grhm
Essential Contributor
 
Join Date: Mar 2007
Location: UK
Posts: 221
Yes, they're emoji characters.
Try copying them from here and pasting them into the 'nickname' field.
Grhm is offline   Reply With Quote
Old 10 Feb 2021, 02:01 AM   #27
JeremyNicoll
Essential Contributor
 
Join Date: Dec 2017
Location: Scotland
Posts: 241
Quote:
Originally Posted by Grhm View Post
Yes, they're emoji characters.
Try copying them from here and pasting them into the 'nickname' field.
Aha! Thank-you. 👾👾👾👾👾 I've learned a new trick.
JeremyNicoll is offline   Reply With Quote
Old 10 Feb 2021, 03:10 AM   #28
Grhm
Essential Contributor
 
Join Date: Mar 2007
Location: UK
Posts: 221
Possibly the first ever genuinely useful application of emojis!
Grhm is offline   Reply With Quote
Old 10 Feb 2021, 08:18 AM   #29
JeremyNicoll
Essential Contributor
 
Join Date: Dec 2017
Location: Scotland
Posts: 241
Quote:
Originally Posted by Grhm View Post
Possibly the first ever genuinely useful application of emojis!
Well... I've a thing about birds (of the feathered variety), and - elsewhere - quite a lot of my messages, especially if they posit something from a birdie point of view, will have a penguin or duck or two in them.

On Beakbook (as some of my feathered friends call it) if one types < then ( then " then ) in a message - which looks a bit like a bird's head in profile, it automatically becomes a penguin...
JeremyNicoll is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Forum Jump


All times are GMT +9. The time now is 07:46 AM.

 

Copyright EmailDiscussions.com 1998-2013. All Rights Reserved. Privacy Policy