EmailDiscussions.com  

Go Back   EmailDiscussions.com > Email Service Provider-specific Forums > FastMail Forum
Register FAQ Members List Calendar Search Today's Posts Mark Forums Read
Stay in touch wirelessly

FastMail Forum All posts relating to FastMail.FM should go here: suggestions, comments, requests for help, complaints, technical issues etc.

Reply
 
Thread Tools
Old 1 Jun 2018, 11:52 PM   #1
NJSS
Master of the @
 
Join Date: Jul 2002
Location: Hampshire, UK
Posts: 1,191
Replying to an email from one's own domain is blocked

In the last day it has become impossible to reply to an email sent to my domain, using the email address on the incoming email.

To illustrate I send out an email to mybank; the email address from which I send the email is mybank@mydomain.com.

To date when I receive an incoming email sent by my bank to mybank@mydomain.com I would reply from FM & the originators email address would be shown as mybank@mydomain.com.

This no longer happens, the originator is shown as my FM address, which I never give to anyone - HELP please.

NJSS
NJSS is offline   Reply With Quote

Old 2 Jun 2018, 08:17 AM   #2
BritTim
The "e" in e-mail
 
Join Date: May 2003
Location: mostly in Thailand
Posts: 2,640
Go to Settings and check out what you see under Identities and fetch. In the Send Mail as section, you should have an Identity set up for 'mybank@mydomain.com'. Note that if you have many different addresses of 'mydomaon.com' that you sometimes send from, you can create a wildcard Identity ('*@mydomain.com') rather than many individual ones.

Also, if you use an external mail client (such as your phone's mail client) to reply to messages, ensure that 'Force all emails sent through third party email clients to come from this address' is not checked.
BritTim is offline   Reply With Quote
Old 2 Jun 2018, 04:23 PM   #3
Terry
The "e" in e-mail
 
Join Date: Jul 2002
Location: VK4
Posts: 2,579
Go to setting then preference, look down the bottom of the page for reply from the same account the message is sent from, tick that box.
Terry is offline   Reply With Quote
Old 2 Jun 2018, 04:48 PM   #4
NJSS
Master of the @
 
Join Date: Jul 2002
Location: Hampshire, UK
Posts: 1,191
Many thanks Terry & BritTim

I have probably 300 or so email addresses at my domain; for Amazon, Waitrose, M+S & every other supplier with whom I communicate. None of them have been set up separately, although I, of course, have the wildcard *@mydomain.com.

What has happened is that there has been a sudden change in how things work. I guess FM have done something & will have to take it up with them.

I was hoping someone else might have noticed this.

Thanks again.

NJSS
NJSS is offline   Reply With Quote
Old 2 Jun 2018, 04:54 PM   #5
Terry
The "e" in e-mail
 
Join Date: Jul 2002
Location: VK4
Posts: 2,579
I did away with the wild card as I got lots of spam.

Last edited by Terry : 2 Jun 2018 at 05:14 PM.
Terry is offline   Reply With Quote
Old 2 Jun 2018, 05:51 PM   #6
BritTim
The "e" in e-mail
 
Join Date: May 2003
Location: mostly in Thailand
Posts: 2,640
There is one other setting that might be implicated in what you see. There is an advanced Folder setting that allows you to override the Default Identity used when replying to messages in a folder. Perhaps, you can resolve your problem by setting this to your wildcard Identity for your domain in the folder where you receive the messages in question.
BritTim is offline   Reply With Quote
Old 3 Jun 2018, 12:50 AM   #7
Grhm
Senior Member
 
Join Date: Mar 2007
Location: UK
Posts: 110
I use a similar system, using a different address for each person or entity with which I communicate, often inventing them on-the-fly when needed.
Everything seems to be working as usual today... but I have never found it to work the way you describe.
When replying to mail sent to an address for which I have no identity (caught by the catch-all) Fastmail has always used the default address as the 'from' address rather than the address to which the mail was sent.
This can be changed before sending by selecting the catch-all address from the 'from' drop-down and typing in the desired address.
You can guard against inadvertently revealing your main FM address by setting the default 'from' address to be something you have never used, but which is different from your main FM address: If you inadvertently send from that address it's no big deal, you can just change the default to something else.
By the way, in case you didn't know, the catch-all *.yrdomain.com catches mail sent to arbitraryname@arbitrarysubdomain.yrdomain.com as well as to arbitraryname@yrdomain.com ...which vastly increases the range of addresses you can use.

P.S. Please keep us informed. If there's a reliable way, short of setting up a separate identity for each address you give out, to make Fastmail always use the received-at address as the 'from' address of any reply, then that would be fantastically useful.

Last edited by Grhm : 3 Jun 2018 at 08:25 AM. Reason: Minor re-wording for clarity; added a P.S.
Grhm is offline   Reply With Quote
Old 26 Jun 2018, 01:49 PM   #8
DumbGuy
Senior Member
 
Join Date: Oct 2008
Posts: 159
I've been using the exact same system for years, and I'm glad to hear of others doing the same.

Most of my incoming mail that I might reply to comes to only a handful of specific addresses -- so I create an identity for each of them. The other dozens-and-dozens of email addresses I receive email from (corresponding to various companies/websites I work with), I rarely need to reply to (often they are newsletters), so I don't bother with specific identities.

I also use the catch-all, both for incoming email routing, and for the identity on each of my 2-4 domains. On those occasions where I want to reply from a specific SomeSpecialCompany@MyDomain.com , I can quickly edit the From address in the email window before I send. No problem.

Quick question for others using this system.... Have you ever suddenly stop receiving email (like a newsletter) from a particular sender, when you know you should still be on their mailing list? This has happened to me a few times, and I wonder if the senders in such cases are somehow blacklisting the outgoing email, thinking it's a spam recipient, being that the username is their website/company name.

For example: I used to subscribe to Meetup.com as meetup@MyDomain.com . At some point their emails simply stopped arriving. It was very frustrating to not get alerts, etc. Well, I logged in and changed my registered email address with them to something completely different, like meat4849@MyDomain.com, and suddenly emails began again. Hmmm...

I have a few other companies in this situation, but I still need to sit down and update my email addresses with them, and see if it works.

But I wonder if this is a common problem for users like us who manage our email addresses in this way. (Also, I wonder if this could be a spam handling bug on the receiving end - by Fastmail.)

Apologies if this post is considered hijacking this thread. If so, I can delete and start a new thread.
DumbGuy is offline   Reply With Quote
Old 26 Jun 2018, 04:35 PM   #9
JeremyNicoll
Junior Member
 
Join Date: Dec 2017
Location: Scotland
Posts: 16
Quote:
Originally Posted by DumbGuy View Post
For example: I used to subscribe to Meetup.com as meetup@MyDomain.com . At some point their emails simply stopped arriving.
I'm a Meetup user and recently one of the things many of us have discussed at meetings is how unreliable Meetup's emails have become. Some people think it's because they also use the Meetup 'app' and so ordinary notification emails have been stopped. I don't use the 'app' at all, and as far as I know I get most emails for most of my groups, but I'm not sure that I get them all. We also all have difficulty finding things, eg the "good to see you" options on the Meetup website. It was all alright until they "improved" it.
JeremyNicoll is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Forum Jump


All times are GMT +9. The time now is 11:53 AM.

 

Copyright EmailDiscussions.com 1998-2013. All Rights Reserved. Privacy Policy