EmailDiscussions.com  

Go Back   EmailDiscussions.com > Email Service Provider-specific Forums > FastMail Forum
Register FAQ Members List Calendar Search Today's Posts Mark Forums Read
Stay in touch wirelessly

FastMail Forum All posts relating to FastMail.FM should go here: suggestions, comments, requests for help, complaints, technical issues etc.

Reply
 
Thread Tools
Old 22 Sep 2019, 04:23 PM   #16
xyzzy
Senior Member
 
Join Date: May 2018
Posts: 186
Aaaarrrrrggggghhh!

Maybe I should never have opened my Spam Protection settings to take a look in there. Because now my add spam {SPAM XX.X} setting is gone (again) too.

I reopend my ticket anyhow.
xyzzy is offline   Reply With Quote
Old 23 Sep 2019, 06:18 PM   #17
JamesHenderson
Essential Contributor
 
Join Date: Jan 2003
Location: Oxfordshire, UK
Posts: 486
Quote:
Originally Posted by xyzzy View Post

I reopend my ticket anyhow.
let us know how that goes...
JamesHenderson is offline   Reply With Quote
Old 1 Oct 2019, 04:26 PM   #18
xyzzy
Senior Member
 
Join Date: May 2018
Posts: 186
My ticket was updated the other day with a post saying they "asked our developers to make this manual adjustment for you once again". It appeared today. Was almost afraid to check the Spam Protection settings for fear it might disappear again. Since it came back with a 5.0 setting I set it to my 6.2 value and it's still there. Given the history of this it's like walking on eggshells every time I go back into Spam Protection wondering if Add Spam will disappear again.

Getting a lot if mileage out of that ticket!

I should mention that when I reopened that ticket to request it be put back again I included my arguments why preferences -> advanced -> reading -> extra headers -> X-Spam-score is not a substitute for Add Spam. Don't know if they bought that argument or not but at least I got the desired result...for now.

Last edited by xyzzy : 1 Oct 2019 at 04:35 PM.
xyzzy is offline   Reply With Quote
Old 1 Oct 2019, 04:51 PM   #19
JamesHenderson
Essential Contributor
 
Join Date: Jan 2003
Location: Oxfordshire, UK
Posts: 486
Quote:
Originally Posted by xyzzy View Post
My ticket was updated the other day with a post saying they "asked our developers to make this manual adjustment for you once again". It appeared today. Was almost afraid to check the Spam Protection settings for fear it might disappear again. Since it came back with a 5.0 setting I set it to my 6.2 value and it's still there. Given the history of this it's like walking on eggshells every time I go back into Spam Protection wondering if Add Spam will disappear again.

Getting a lot if mileage out of that ticket!

I should mention that when I reopened that ticket to request it be put back again I included my arguments why preferences -> advanced -> reading -> extra headers -> X-Spam-score is not a substitute for Add Spam. Don't know if they bought that argument or not but at least I got the desired result...for now.
well done!
What's the exact name of this tick box so we can ask for it back as well?
JamesHenderson is offline   Reply With Quote
Old 1 Oct 2019, 06:50 PM   #20
Terry
The "e" in e-mail
 
Join Date: Jul 2002
Location: VK4
Posts: 2,829
I asked them to do mine and they would not do it, so it may depend on who dos the ticket.

Its called Add score as {SPAM XX.X} to subject when the spam score is or more

After mine was removed I got lots of US spam to just one Fastmail domain....I am still getting spam to that domain so I diverted the mail to outlook that way the spam is not in my fastmail box.

Last edited by Terry : 1 Oct 2019 at 06:56 PM.
Terry is offline   Reply With Quote
Old 1 Oct 2019, 07:08 PM   #21
JamesHenderson
Essential Contributor
 
Join Date: Jan 2003
Location: Oxfordshire, UK
Posts: 486
Quote:
Originally Posted by Terry View Post
I asked them to do mine and they would not do it, so it may depend on who dos the ticket.

Its called Add score as {SPAM XX.X} to subject when the spam score is or more
Thanks - that's a shame though.
JamesHenderson is offline   Reply With Quote
Old 1 Oct 2019, 07:19 PM   #22
Terry
The "e" in e-mail
 
Join Date: Jul 2002
Location: VK4
Posts: 2,829
Yea sad but cant change things but the domain is useless now, I just don't understand why only US spam to one domain.
Terry is offline   Reply With Quote
Old 1 Oct 2019, 07:21 PM   #23
JamesHenderson
Essential Contributor
 
Join Date: Jan 2003
Location: Oxfordshire, UK
Posts: 486
do you use a catchall with that domain or a specific email; address? I ask because I can only assume it has been used differently at some point and ended up on a spammers hit list. ...may not have been you that did this of course.
JamesHenderson is offline   Reply With Quote
Old 1 Oct 2019, 07:35 PM   #24
Terry
The "e" in e-mail
 
Join Date: Jul 2002
Location: VK4
Posts: 2,829
I did not but perhaps the last user did.

The silly thing was I have had it for a few months without any spam and suddenly the spam started arriving. I have only used it a couple of times and have not listed it anywhere.
Terry is offline   Reply With Quote
Old 1 Oct 2019, 07:37 PM   #25
JamesHenderson
Essential Contributor
 
Join Date: Jan 2003
Location: Oxfordshire, UK
Posts: 486
is the domain yours or one of Fastmail's?
JamesHenderson is offline   Reply With Quote
Old 1 Oct 2019, 07:50 PM   #26
Terry
The "e" in e-mail
 
Join Date: Jul 2002
Location: VK4
Posts: 2,829
Fastmail.com
Terry is offline   Reply With Quote
Old 1 Oct 2019, 08:02 PM   #27
JamesHenderson
Essential Contributor
 
Join Date: Jan 2003
Location: Oxfordshire, UK
Posts: 486
yes, I think you have just been unlucky.
JamesHenderson is offline   Reply With Quote
Old 1 Oct 2019, 10:24 PM   #28
FredOnline
The "e" in e-mail
 
Join Date: Apr 2011
Location: Manchester UK
Posts: 2,251
The only problem I've ever had with spam in my FastMail account was when FastMail obtained the fastmail.com domain, and I thought I was lucky in getting my first name as an alias for that domain.

Unfortunately, as soon as it was live I started getting spam to that address, so that it's now whitelist only and is basically useless as an e-mail address!

Apart from that, ZERO problems with spam.

IMHO, you must look at yourself and think about where and to whom you give out an e-mail address.

As for fiddling with your spam settings, I have never had the need - it's akin to fiddling with your car engine to improve performance, and then finding you can't get it started!
FredOnline is offline   Reply With Quote
Old 2 Oct 2019, 06:22 AM   #29
xyzzy
Senior Member
 
Join Date: May 2018
Posts: 186
Quote:
Originally Posted by FredOnline View Post
As for fiddling with your spam settings, I have never had the need - it's akin to fiddling with your car engine to improve performance, and then finding you can't get it started!
Heh, I've been fidding with it for a better part of a year after I started using FM. That's why I liked the Add Spam option so much. Made it easier to see the spam values just looking the folders I was filtering spam into (two classes originally - blacklisted repeat offenders with lower spam scores and other spam). Since the spam training kicked in after reaching the 200-learned threshold the blacklist stuff now has much higher scores and the spam dropped off considerably (although today I got 14 which is a new recent record).

I settled on a spam threshold of 6.2 and a spam discard threshold as 9.1. That cut off all the spam. So a a while ago I disabled the spam cutoff (I think that's when I lost the Add Score) just to verify what kind of crap was being discarded. And sure enough that's where the blacklisted stuff was now being scored and the other spam all have double digit scores. I think now I am almost ready to re-enable my spam discard threshold (9.1) again (hope the Add Score stick).
xyzzy is offline   Reply With Quote
Old 5 Oct 2019, 06:24 AM   #30
xyzzy
Senior Member
 
Join Date: May 2018
Posts: 186
For those of you who lost the Add Spam Spam Protection setting (and me who got it back but in anticipation of probably losing it again someday) where emails classed as spam have their subject line prefixed with "{SPAM XX.X}" and can't convenience FM to re-enable it, I came up with a way to simulate with some sieve code.

There's an unrelated thread where a poster named verbovet posted a snippet of sieve code (post 14 in that thread) that used deleteheader/addheader on the "From" header. I never even thought about using them before on a header normally displayed in the email. So that gave me the idea of doing the same thing with the Subject header to simulate the Add Spam setting for those that lost it and want it back.

Code:
if allof(false, # change to true to enable should Add Spam be removed
         header :value "ge" :comparator "i;ascii-numeric" "X-Spam-score" "${SPAM_THRESHOLD}",
         header :matches "Subject" "*") {
  set "subject" "${1}";
  if header :matches "X-Spam-score" "*" {
    set "spam_score" "${1}";
    if header :value "lt" :comparator "i;ascii-numeric" "X-Spam-score" "10" {
      set "spam_score" "0${1}"; # add leading 0 for spam scores < 10
    }
    deleteheader "Subject";
    addheader "Subject" "{SPAM ${spam_score}} ${subject}";
  }
}
A convenient place for this code is near the beginning, i.e., before section 1. I have other stuff in there already including setting of the variable SPAM_THRESHOLD used in the above code, for example,

set "SPAM_THRESHOLD" "6.2";

Thanks verbovet for giving me the idea.

Last edited by xyzzy : 5 Oct 2019 at 07:06 AM.
xyzzy is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Forum Jump


All times are GMT +9. The time now is 03:23 PM.

 

Copyright EmailDiscussions.com 1998-2013. All Rights Reserved. Privacy Policy