EmailDiscussions.com  

Go Back   EmailDiscussions.com > Email Service Provider-specific Forums > FastMail Forum
Register FAQ Members List Calendar Search Today's Posts Mark Forums Read
Stay in touch wirelessly

FastMail Forum All posts relating to FastMail.FM should go here: suggestions, comments, requests for help, complaints, technical issues etc.

Reply
 
Thread Tools
Old 11 Aug 2017, 05:22 AM   #1
sebwills
Junior Member
 
Join Date: Jan 2015
Posts: 9
Android app mangles text when editing

I use the Fastmail android app on my phone (Moto G4, Android 7.0). Mostly it works fine, but if I edit text that I am composing (i.e. move the caret back into text I've already written and make changes), it goes badly wrong, corrupting surrounding words when inserting characters, to the point where it is impossible to continue editing. Adding text at the end of a paragraph seems ok.

E.g. compose new message, write "test message", then position cursor before the first character and type "real" followed by a space. About 30% of the time this corrupts the text, eg to "*messReal Testage". The corruption seems much more likely and more severe if I use the 'glide writing' Google keyboard feature were you trace out words without lifting your finger, but I also see it when doing normal tapping. I think it's always when inserting a space.

I'm using the default Google keyboard, in UK English. I've been experiencing this for many months, and my wife also gets it. I've only ever noticed it in the Fastmail app. For example, there is no problem composing text in Chrome. Though my wife says it affects the Facebook app too.

Has anyone else experienced this - in Fastmail or any other app? (I realise it might not be the Fastmail app's fault - though as I said personally I've only ever seen it there)
sebwills is offline   Reply With Quote

Old 11 Aug 2017, 07:45 AM   #2
n5bb
Intergalactic Postmaster
 
Join Date: May 2004
Location: Irving, Texas
Posts: 8,236
I don't have an Android device (only iOS devices). I recommend that you file a Fastmail support request concerning this topic.

Bill
n5bb is offline   Reply With Quote
Old 11 Aug 2017, 02:32 PM   #3
joe_devore
Essential Contributor
 
Join Date: Dec 2003
Location: Dover, NH, USA
Posts: 294
Wink

I ran a test of the compose screen on my
- Samsung Galaxy S7 (Android of course)...

no problem for me, text is typed just fine and moving the cursor around and adding more text did not cause any corruption for me...
joe_devore is offline   Reply With Quote
Old 11 Aug 2017, 04:16 PM   #4
janusz
The "e" in e-mail
 
Join Date: Feb 2006
Location: EU
Posts: 4,441
On my two different Android (6.0.1) devices I see a similar text mangling behaviour in all applications but with the Swiftkey keyboard. The default keyboard behaves impeccably.

BTW I do not have the FM application, so I'm not sure this clarifies the matter at all.
janusz is offline   Reply With Quote
Old 20 Aug 2017, 11:57 AM   #5
radtux
Senior Member
 
Join Date: Nov 2010
Posts: 133
I had faced this issue with default keyboard (Google) and SwiftKey. However, I installed BlackBerry Keyboard from the Cobalt Manager and this issue is resolved completely. I think it had to do with the bugs in the keyboard rather than the app itself.

Let me know if you need any help with the BlackBerry Keyboard (which works almost perfectly) instead.

(My device- MotoG5 with Android 7).
radtux is offline   Reply With Quote
Old 23 Aug 2017, 09:38 AM   #6
FortyTwo
Junior Member
 
Join Date: Jan 2014
Location: Melbourne
Posts: 9
[quote=sebwills;603544]I use the Fastmail android app on my phone (Moto G4, Android 7.0). Mostly it works fine, but if I edit text that I am composing (i.e. move the caret back into text I've already written and make changes), it goes badly wrong, corrupting surrounding words when inserting characters, to the point where it is impossible to continue editing. Adding text at the end of a paragraph seems ok. /[quote]

Yes, got problem too. Only with FastMail app - gesture typing worked fine in other apps, although I don't have Facebook app. Typing email replies was tedious, particularly going back to a previous word to edit/add something. Happened with default android keyboard US or UK, and with SwiftKey. Gesture typing seemed too fast for the fastmail app 😕

I uninstalled the FM app. Now using web app only. Don't get email notifications, so others may not want that, but it's much faster on my moto g4+ with 2GB RAM. And RAM usage is way down. FM app would creep up to over 200MB. Web app Max 20MB. That said, my phone's total RAM doesn't get over 1.3GB, so I have no idea what's the issue.
FortyTwo is offline   Reply With Quote
Old 23 Aug 2017, 09:54 AM   #7
FortyTwo
Junior Member
 
Join Date: Jan 2014
Location: Melbourne
Posts: 9
Sorry about the Quote in my above post.

Forgot to add that I haven't had one instance of the mangled text when using FM as the web app, regardless of whether I use default or other keyboards, with or without gesture typing.
FortyTwo is offline   Reply With Quote
Old 14 Sep 2017, 04:53 AM   #8
mgg
Member
 
Join Date: May 2003
Location: Toronto, Canada
Posts: 75
Just posted about this

Aha! others also seeing this issue.

I just posted about it (sorry, searched forum and didn't see your post 'til now). Here's my thread:
http://www.emaildiscussions.com/showthread.php?t=72975

And I included a video of the problem, on my Google Pixel XL.
https://photos.app.goo.gl/U7GDoay9MKMzNoUH2

It does seem related to the Google Keyboard, but it also seems unique to Fastmail. I can't change keyboards easily on the Pixel and don't really want to because I do love the GBoard in every other app.

Help!

Thanks,
<M>
mgg is offline   Reply With Quote
Old 14 Sep 2017, 06:02 AM   #9
sebwills
Junior Member
 
Join Date: Jan 2015
Posts: 9
Thanks to everyone for your responses. Helpful to know others are seeing the problem.

@radtux - could you explain how to get the Blackberry keyboard? Is it the 'Keyboard for Blackberry' app? That didn't look quite right from the description.

@mgg - interesting that you see it on a Pixel. Everyone who has the problem on this thread so far has had a Moto so I had been thinking it was something Moto-specific.

I did report the issue to Fastmail (ticket 368552) - the agent said they couldn't reproduce on their phone and suggested reinstalling the app, which I just tried - no improvement. I will follow up and point them to these threads.

I am coming to the conclusion that I should just abandon the app and use the web interface or another mail app. Getting frustrated with slow inbox loading and lack of offline access anyway....
sebwills is offline   Reply With Quote
Old 14 Sep 2017, 06:06 AM   #10
mgg
Member
 
Join Date: May 2003
Location: Toronto, Canada
Posts: 75
Thanks. I just submitted another bug report along with a link to my video, and referenced your ticket number as well.

Unfortunately I can't use other apps for email because I make heavy use of folders and they don't handle them properly (eg. respect fastmail's hierarchy/ordering).

I'll try the web interface again -- I used to use it, can't remember why I switched to the app.

<M>
mgg is offline   Reply With Quote
Old 14 Sep 2017, 07:26 AM   #11
gardenweed
Essential Contributor
 
Join Date: Jun 2008
Location: Perth
Posts: 469
Quote:
Originally Posted by mgg View Post
......
I'll try the web interface again -- I used to use it, can't remember why I switched to the app.

<M>
Probably because the app has push - so you get notificaitons, but the web interface does not.

I find if I close FM on my phone, and then open it before I read or try to send an email, it more often behaves properly. Otherwise it usually hangs trying to connect to the server. I have also experienced the whacky/mangled text issue.

(Galaxy S6)
gardenweed is offline   Reply With Quote
Old 14 Sep 2017, 12:47 PM   #12
mgg
Member
 
Join Date: May 2003
Location: Toronto, Canada
Posts: 75
Quote:
Originally Posted by gardenweed View Post
Probably because the app has push - so you get notificaitons, but the web interface does not.)
Myeah.... but that's not it -- we've turned off push and instead use the 'Pushover' service to create custom push notifications for only very specific emails; otherwise it would be craziness. Just tried the web app, and one of the other benefits is you can create shortcuts on the home page(s) to specific mailboxes or activities like 'compose'. That's actually great, because one of my peeves about the app was that it could not be set to open to a specified folder, only to the generic 'inbox'.

Maybe this will work better all around....
mgg is offline   Reply With Quote
Old 15 Sep 2017, 06:26 AM   #13
sebwills
Junior Member
 
Join Date: Jan 2015
Posts: 9
Fastmail support replied to my follow-up. They say:

Quote:
We've investigated and found this bug is happening in the Crosswalk framework that our app is built on, which unfortunately is no longer maintained. We need to move it to a different framework.
As well as suggesting using the web interface, they also pointed out that if you change the settings to compose plain text rather than rich text messages then the issue doesn't occur. (Settings -> Mail Preferences screen, under the Writing section.). Useful to know.
sebwills is offline   Reply With Quote
Old 15 Sep 2017, 10:51 PM   #14
mgg
Member
 
Join Date: May 2003
Location: Toronto, Canada
Posts: 75
Quote:
Originally Posted by sebwills View Post
...As well as suggesting using the web interface, they also pointed out that if you change the settings to compose plain text rather than rich text messages then the issue doesn't occur. (Settings -> Mail Preferences screen, under the Writing section.). Useful to know.

I just tried this, and the problem remained, on my Pixel XL. Just FYI.

<M>
mgg is offline   Reply With Quote
Old 19 Sep 2017, 11:34 AM   #15
FortyTwo
Junior Member
 
Join Date: Jan 2014
Location: Melbourne
Posts: 9
Quote:
Originally Posted by mgg View Post
I just tried this, and the problem remained, on my Pixel XL. Just FYI.

<M>
Yes, I tried using plain text (a while back) when I was using the FM app. The text was still getting mangled on my Moto.
FortyTwo is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Forum Jump


All times are GMT +9. The time now is 02:50 PM.

 

Copyright EmailDiscussions.com 1998-2013. All Rights Reserved. Privacy Policy