EmailDiscussions.com

Go Back   EmailDiscussions.com > Email Service Provider-specific Forums > FastMail Forum
Register FAQ Members List Calendar Search Today's Posts Mark Forums Read

FastMail Forum All posts relating to FastMail.FM should go here: suggestions, comments, requests for help, complaints, technical issues etc.

Reply
 
Thread Tools
Old 6 Jan 2012, 02:19 AM   #1
kem312
Junior Member
 
Join Date: Jan 2012
Location: Hampshire, England
Posts: 4
Missing folders

I have been using Fastmail for 7 years and have never had anything like this happen. I have raised a support ticket but I haven't heard anything yet and I really need to access some of my missing folders so I wondered if anyone on here could help.

I have an enhanced account and have a number of folders and subfolders set up that I use to store my business emails. One of these folders is for customers and has a subfolder for each customer I have (about 50).

This morning everything was fine but suddenly I went to move an email from my inbox but the customer subfolders along with a couple of other subfolders were no longer there. Most of other folders and subfolders are still there.

Strangely my mailbox size is still the same as it was before these disappeared and there is 7 years worth of email in the missing folders (the bulk of my emails) so this seems odd.

I did an account verification test and it lists the subfolders as still being there.

I did a search for an email that I know I moved to one of my customer subfolders this morning and it could not find it.

The missing subfolders do not show up on my mail screen or in the create/edit folder screen.

I have also tried a restore and that has not produced any of the missing subfolders/emails nor are they in the trash folder.

I only use Fastmail on the internet and iphone and cannot see the missing folders on either.

I'm at a bit of a loss and would be very grateful for some help.
kem312 is offline   Reply With Quote

Old 6 Jan 2012, 02:42 AM   #2
Peekay
Member
 
Join Date: Jul 2004
Location: Bolton, England
Posts: 83
Not sure if it helps, but this thread discusses some Fastmail interface display problems on iPad and iPhone. Maybe a CSS or script issue causes nested folders to be hidden in the latest version of the Safari browser? This might not happen until your browser was updated.
Peekay is offline   Reply With Quote
Old 6 Jan 2012, 03:03 AM   #3
kem312
Junior Member
 
Join Date: Jan 2012
Location: Hampshire, England
Posts: 4
Thanks very much for this. Unfortunately my main use is on a pc using internet explorer not an ipad so I don't think this is relevant. I just checked it was the same on my iphone just in case it was a problem specific to my pc but it is the same on both.
kem312 is offline   Reply With Quote
Old 6 Jan 2012, 03:48 AM   #4
FredOnline
Master of the @
 
Join Date: Apr 2011
Location: Manchester UK
Posts: 1,211
While you're waiting for a response to your support ticket.

Have you checked your login log (Options/Status/Login Log) for any unusual activity?
FredOnline is offline   Reply With Quote
Old 6 Jan 2012, 04:05 AM   #5
kem312
Junior Member
 
Join Date: Jan 2012
Location: Hampshire, England
Posts: 4
Yes, I checked this earlier. It all seems to be from my pc.
One additional thing I have noticed since my original post:

I have tried to create some new test subfolders to see what happens. I can create them as normal under most folders but I cannot create them on the folders where the subfolders have gone missing. No error message comes up but they are not there when I scroll down the folders screen.

I believe they are being created though as I have gone through the verify account process again and they are there.

I really am confused.
kem312 is offline   Reply With Quote
Old 6 Jan 2012, 04:31 AM   #6
alexkingorg
Junior Member
 
Join Date: Nov 2005
Location: Denver, CO
Posts: 7
Exclamation Same Problem

I'm experiencing the exact same issue. I have been a customer for years with no issues, and late last night a bunch of subfolders "disappeared" for me. I access my account exclusively through IMAP, but did log into the web interface today to confirm that the folders are not present there either.

I too had a bunch of subfolders with a large amount of emails in them. It appears that the subfolders are only missing under a single prent folder - other subfolders have not been affected.

I too have opened a ticket and have not heard anything back yet.

Last edited by ReuvenNY : 6 Jan 2012 at 10:59 AM. Reason: Signature removed.
alexkingorg is offline   Reply With Quote
Old 6 Jan 2012, 04:46 AM   #7
kem312
Junior Member
 
Join Date: Jan 2012
Location: Hampshire, England
Posts: 4
Thank goodness it isn't just me.
I agree not all of my subfolders are missing, just all of those under two of my parent folders.
kem312 is offline   Reply With Quote
Old 6 Jan 2012, 05:24 AM   #8
brado77
Junior Member
 
Join Date: Jan 2012
Posts: 7
Hosed as well

Count me in -- I am also a customer of nearly a decade, and I lost 6 folders containing over 2400 emails (which were in a parent folder) -- which happened to be 100% of my email for my current customers. Please also read this thread I just posted:

http://www.emaildiscussions.com/showthread.php?t=63735

My post documents what I've done so far, and it establishes quite clearly that there's some kind of major data corruption on the Fastmail server side. Note that Fastmail's restore process does not show these lost folders as deleted, which is extremely troubling.

I have also opened a support ticket and have not had any response yet. Please continue to post here if you have any progress.

Thanks.
brado77 is offline   Reply With Quote
Old 6 Jan 2012, 05:35 AM   #9
alexkingorg
Junior Member
 
Join Date: Nov 2005
Location: Denver, CO
Posts: 7
Noting brado77's timeline:

Quote:
Indeed, my folders were still there, so that confirms that this deletion happened some time between last night (the last time I used my notebook) and mid-day today.
I first noticed this between 7pm-11pm US/Mountain (UTC -7) last night, but figured it was a mail client glitch. This morning I confirmed in the web interface that the folders are indeed not visibly present in my account or accessible.

Sounds like we're all seeing the same thing - the folders are in some way "hidden", but likely still exist on the server in some manner.
alexkingorg is offline   Reply With Quote
Old 6 Jan 2012, 11:54 AM   #10
alexkingorg
Junior Member
 
Join Date: Nov 2005
Location: Denver, CO
Posts: 7
Anyone get a reply from support yet?
alexkingorg is offline   Reply With Quote
Old 6 Jan 2012, 12:31 PM   #11
neilj
Cornerstone of the Community
 
Join Date: Apr 2004
Location: Melbourne
Posts: 918

Representative of:
Fastmail.fm
When rolling out a fix for another IMAP bug yesterday, we accidentally broke the LIST command (this returns the list of folders to IMAP clients, including the web interface) under certain circumstances.

No data has been lost. The folder is there, it's just not showing in the list. We have identified the problem and will roll out a fix as soon as possible, almost certainly within the next 12 hours.

Sorry for the inconvenience,

Neil.
neilj is offline   Reply With Quote
Old 6 Jan 2012, 12:37 PM   #12
alexkingorg
Junior Member
 
Join Date: Nov 2005
Location: Denver, CO
Posts: 7
Thumbs up

Thanks Neil, very much appreciate the update.
alexkingorg is offline   Reply With Quote
Old 6 Jan 2012, 12:50 PM   #13
brado77
Junior Member
 
Join Date: Jan 2012
Posts: 7
Thanks for the update, Neil. While you are at it, you might also want to fix the verify function. I ran it on my account it caused a good number of legitimately deleted folders to reappear (unfortunately not the ones in question), and resulted in hundreds of duplicated and deleted email messages being added to mail folders throughout the mail hierarchy.
brado77 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Forum Jump


All times are GMT +9. The time now is 11:36 PM.

 

Copyright EmailDiscussions.com 1998-2013. All Rights Reserved. Privacy Policy