View Single Post
Old 8 Nov 2016, 08:33 AM   #4
Berenburger
The "e" in e-mail
 
Join Date: Sep 2004
Location: The Netherlands
Posts: 2,387
Updated!

Quote:
Originally Posted by JamieKitson View Post
I don't know if anyone else has achieved this yet, but I have been trying for months and months and have finally got CardDAV working on Windows Phone 8.1.
  1. Add an iCloud account.
  2. Set the email address to your fastmail email address, but add "+Default" after the name part so you have, for example "name+Default@fastmail.com".
  3. Put in your password (if you're not aware you can create an alternate login for this so you don't have to use your master password).
Replace line 3 with a New App Password in the App Passwords section. Choose CardDAV as the type of data this app needs access to.
Quote:
  1. Tap "sign in".
  2. Tap the newly created iCloud account.
  3. Change the account name to something meaningful.
  4. Make sure Contacts is ticked to sync.
  5. Untick sync Calendar.
  6. Tap "advanced settings" at the bottom of the page.
  7. Edit the "Contacts server (CardDAV)" to:
    "carddav.messagingengine.com:443/dav/addressbooks/user/username@fastmail.com/Default"
    Obviously changing "username@fastmail.com" as appropriate. Note the missing "https://" and the added port number.
7. You can also use the new fastmail.com domain here: carddav.fastmail.com instead of carddav.messagingengine.com.

Quote:
  1. Tap the tick to save your changes.
  2. Your Fastmail contacts should now sync.
Note that you can't use the same account instance on your phone for both Calendar and Contacts because the usernames are different.

https://beta.fastmail.com/help/techn...44101#contacts
Works also on Windows Mobile 10.

Last edited by Berenburger : 8 Nov 2016 at 09:00 AM.
Berenburger is offline   Reply With Quote