View Single Post
Old 11 Jun 2008, 08:17 PM   #2
Intergalactic Postmaster
Join Date: Oct 2001
Location: Melbourne, Australia
Posts: 6,102

Representative of:
Ah neat, looking up a bit, here's what to do. A little annoying that it's multi-step, but anyway...

1. Type "about:config" in the address bar
2. Search for allowRegisterFromDifferentHost, and it should find an entry called gecko.handlerService.allowRegisterFromDifferentHost
3. Right-click the entry and select Toggle to make it true (this opens a temporary security hole we close in step 7 below)
4. Ctrl-T to open a new tab
5. In the addressbar, enter:

6. It should popup something about "Add this handler?" Click the button to accept it. Close the tab.
7. Go back to the about:config tab, and toggle the setting again to false (this closes the temporary security hole)

That's it, mailto: links in Firefox should now go to FastMail.

To completely remove the handler if you ever want to, go to Tools -> Options -> Applications tab. Enter "mailto" in the search field. You'll see an entry that as "mailto" on the left, and a popup menu on the right. Select "Application details..." from the popup menu. You can Remove the FastMail handler there.

robmueller is offline   Reply With Quote