View Single Post
Old 24 Sep 2017, 02:31 AM   #8
fmett
Junior Member
 
Join Date: Aug 2016
Posts: 6
Quote:
Originally Posted by exactus View Post
So I am trying to use the same config from my phone to my friend's phone. But I suspect they may be different versions of the app.

(One mistake I did make was to use a new app password rather than the existing app password created for a tablet some months ago. But reverting to the existing app password hasn't helped.)
Hmmm. I'm trying to duplicate what I think you are doing. Before I continue, I normally use the Fastmail app.
On support page https://www.fastmail.com/help/clients/android.html
FM say "FastMail has an excellent Android app which many of our users prefer to other mail apps" - frankly, I don't know if that was ever true, either that the app is "excellent" or that many FM users prefer it.
I documented some of my frustrations here:
http://www.emaildiscussions.com/show...4&postcount=19
... and I have received a suggestion from FM support _not_ to use their "excellent" app. You are probably better off without it.

In the Gmail app, you are correct that FM's Gmail app setup instructions at https://www.fastmail.com/help/clients/android.html are out of date, so I'm just following the flow in the Gmail "Add Account" to add the FM account with a new app password I have not previously needed, generated with device= Android and Access = imap.

I am failing, also, but in a stranger way than you. I can set and apparently validate the "incoming mail" - Gmail is happy with that - but, when I proceed to outgoing mail, with
server=smtp.fastmail.com
port=465
security=SSL/TLS
... and with my FM username and FM app password (just used immediately prior for incoming mail) copied and pasted and visually verified to be identical, Gmail says
"validating smtp settings ... Your usename or password is incorrect".

In the FM logins log, I can see the successful login for incoming
"imap SUCCESS 2 App password: Android"
... and then the failure for outgoing ...
"smtp FAIL 6 "
... but there is so little info displayed that the log is useless. I already know it failed.

But I'll tell you something I noticed along the way which may give a clue as to what is happening. I first experimented using a password that was deliberately invalid because I wanted to see what error messages I'd receive. Of I course I failed the "incoming" stage (not having progressed to the "outgoing" stage), and then, when I used the correct password for incoming and that validated and I passed to configuring the "outgoing", something odd happened...

Referring to stage "6" of FM's Gmail setup instructions, they say regarding the "outgoing" Set the server settings for outgoing mail.
---- quote
Server is smtp.fastmail.com
Security type is SSL/TLS
Password should be pre-filled: it's your app password.
----- end quote
"Password should be pre-filled: it's your app password" was not true - it was set to the experimental deliberately-invalid password I have initially used and which I had then replaced by the correct password that validated for incoming. So I explicitly pasted in the correct app password, and then got stuck on the failure condition.

You seemed to indicate that you had initially used an incorrect password. I'm wondering if these incorrect passwords are being cached somewhere and not being overwritten when a better password is later supplied.

I can't think of any other explanation for my failure to pass validation outgoing having passed validation for incoming with the same credentials.

Or is it the case that the Gmail app will require the generation of a second app password, with
Device = Android
Access = smtp
... in which case FM's advice quoted above "Password should be pre-filled: it's your app password" is wrong ?
fmett is offline   Reply With Quote