EmailDiscussions.com

EmailDiscussions.com (http://www.emaildiscussions.com/index.php)
-   FastMail Forum (http://www.emaildiscussions.com/forumdisplay.php?f=27)
-   -   Why does some SMTP aliases work for the same Google account and not others? (http://www.emaildiscussions.com/showthread.php?t=73101)

jagomai 5 Oct 2017 02:24 AM

How do I manually set SMTP details for Identities?
 
==> Edited this as probably the issue is that I can't set manual login details for Identities as before.. Anyone know how to do this?

Original post:

Hi,

I use a Gmail business account for work and link it to my FastMail account because FastMail is better.

I have three aliases that I use for the Gmail business account:

(a) my-username@first-business-email.com

(b) my-username@second-business-email.com

(c) my-username@third-business-email.com

See here for what I see in Google Mail: https://www.evernote.com/l/AotTB-Oh-...nSYswOa5aRga74


(a) and (b) works just fine using SMTP sending from FastMail using FastMail identies: https://www.evernote.com/l/AouAArRCX...b6KwJ4QVmJm1aY

(c) does NOT work for whatever reason (I cannot figure this out at all):
https://www.evernote.com/l/Aot3P3xzs...Zp-L6TXf9ieHwQ


For (a) and (b) and (c) I do the same authentication procedure and when I try to check connection for (a) and (b), it works fine:
https://www.evernote.com/l/AouT3Z-7v...Kph1eEhNS9I1kE


For (c), it does not work:
https://www.evernote.com/l/AouT3Z-7v...Kph1eEhNS9I1kE

It seems to be that setup is the SAME for all three Google account aliases!

I've tried to play around making different Google aliases the "default" one, and the same result - it's only (c) that doesn't work.


Can anyone help out??

Thanks!
J

BritTim 5 Oct 2017 03:17 AM

If the various email addresses use different Google accounts, check out https://myaccount.google.com/lesssecureapps. You may need to enable support for less secure apps.

jagomai 5 Oct 2017 04:49 AM

Quote:

Originally Posted by BritTim (Post 604108)
If the various email addresses use different Google accounts, check out https://myaccount.google.com/lesssecureapps. You may need to enable support for less secure apps.

Yep, thanks, already done.

Also see above that this is for the SAME account.

jagomai 5 Oct 2017 09:39 PM

One question...

How do I manually set login and password for the SMTP links in FastMail for identities?

I don't want to go through the Google wizard etc, I want to manually set SMTP settings.

I think I was able to do this in the classic interface, but now that's been closed. :/

gardenweed 6 Oct 2017 07:54 AM

Quote:

Originally Posted by jagomai (Post 604118)
One question...

How do I manually set login and password for the SMTP links in FastMail for identities?

/

I think what you are looking for is here:
  • Go to Settings -> Identities & Fetch;
  • Select the Identity you want to use by clicking the Edit button;
  • Click on "Show Advanced Preferences";
  • Scroll to the bottom;
  • Click the radio button "Send via"

Now a new set of fields opens up for Outgoing SMTP server settings.

Good luck :)

jagomai 6 Oct 2017 06:12 PM

Hey Gardenweed - thanks for the reply!

I can't set any SMTP settings there. All I see is this:
https://www.evernote.com/l/AosFoGWEq...WdoWW6kIIraPYA

Pressing "re-authenticate" just brings up the standard Google dialog box, where I can choose to authenticate with the main account: https://www.evernote.com/l/AouA0-xuq...zeRu5gdSBCSSRM

Probably there's a bug with this on FastMail's side - since re-authenticating works, but then email sending gets a "username/password is incorrect".

At the point of email sending, I think FastMail tries to authenticate using the IDENTITY email set in FastMail, instead of the Google ACCOUNT email needed for authentication.

And there is no way to set this manually. :/

gardenweed 6 Oct 2017 07:07 PM

Put a tick in "Send Via"

jagomai 6 Oct 2017 07:55 PM

Quote:

Originally Posted by gardenweed (Post 604125)
Put a tick in "Send Via"

Duh. -_-

;)

Look at the screenshots above and also the description. Doesn't work because I'm linked to Google's auth (FastMail DOES NOT allow manual entry for Google accounts it seems)

FredOnline 6 Oct 2017 09:17 PM

Have you tried creating a new identity for a domain that isn't Google/Gmail or a domain you already have in your account?

Then you can edit the SMTP settings manually.

Apologies if I've also misunderstood your question.

jagomai 6 Oct 2017 10:13 PM

Quote:

Originally Posted by FredOnline (Post 604128)
Have you tried creating a new identity for a domain that isn't Google/Gmail or a domain you already have in your account?

Then you can edit the SMTP settings manually.

Apologies if I've also misunderstood your question.

Thanks for the reply!

Yes, and this works well. BUT what I really need is for identities to work for Google accounts.

jagomai 9 Oct 2017 06:55 PM

Made a bug ticket for this: https://www.fastmail.com/support/vie...etKey=PDTLEZLV

Let's see what happens....

jagomai 11 Oct 2017 07:20 PM

Update:

> Unfortunately there's not a lot we can do with this currently. There is a known
bug, which we haven't currently got a timeline to fix, which makes it difficult,
if not impossible, to use an alias (or any other email address not acceptable to
Google as a username), as a sending identity.
>
> We also don't want to encourage people to use non-OAUTH login to Google, so are
reluctant to allow manual entry of SMTP settings/app passwords etc. for Google
addresses.
>
> I've asked the developers to re-prioritise fixing the bug, but they don't know
when it'll happen yet, I'm sorry to say.
>
> Sorry for the inconvenience.


Seems this is on the to do list.


All times are GMT +9. The time now is 12:59 PM.


Copyright EmailDiscussions.com 1998-2013. All Rights Reserved. Privacy Policy