EmailDiscussions.com

EmailDiscussions.com (http://www.emaildiscussions.com/index.php)
-   FastMail Forum (http://www.emaildiscussions.com/forumdisplay.php?f=27)
-   -   alias error, when "poking holes" in wildcard MX (http://www.emaildiscussions.com/showthread.php?t=47962)

eichin 25 Feb 2007 08:41 AM

alias error, when "poking holes" in wildcard MX
 
I'm attempting to follow the second half of FAQ item 9 on the virtual domains page:
http://www.fastmail.fm/docs/faqparts...ernalSubdomain

In particular, I already had thok.org and *.thok.org set up (in DNS and on fastmail), added an MX record for local-kittens.thok.org, went to add "local-kittens.thok.org NONE" to the virtual domains list under options->virtual domains, and got:
"An alias currently uses this domain. You must delete all aliases that use a domain before you can deactivate the domain."

Does this mean that I have to delete the */thok.org entry under "virtual aliases" at the top of that page? I tried experimenting with the corresponding thok.com entries (I actually *use* thok.org, thok.com is just for experimenting), and it didn't work (I got the same error)...

(I don't have *any* aliases under options->settings->aliases, so I assume that's not what it is referring to...)

eichin 25 Feb 2007 01:25 PM

Oh, I think I found it - I get that error if I try to *add* the subdomain with "active" set to none... but if instead I add it as "waiting for DNS", then change it to None and hit update, it takes it; hopefully I'll find out in the next 15m to an hour if it actually works :-) Seems like an odd UI issue, maybe the FAQ could be expanded a little.

n5bb 25 Feb 2007 01:50 PM

Welcome to the EMD Forums, eichin! :)

Here is a post with step by step details which might help you:
Virtual Domain Activation

Bill

eichin 25 Feb 2007 02:36 PM

It all appears to work now - doing it in two steps instead of one did do the right thing.

robmueller 26 Feb 2007 12:54 PM

Interesting, that is a buggy message. I'll make a fix for it.

Rob


All times are GMT +9. The time now is 05:19 PM.


Copyright EmailDiscussions.com 1998-2013. All Rights Reserved. Privacy Policy